¿Cómo configurar QGIS Master y Stable en paralelo en un sistema Linux?

14

Principalmente uso el QGis Master (compilación nocturna) para mi Debian Linux y estoy muy contento con él. Pero para fines educativos y de demostración, ahora tengo que trabajar con la versión Stable (1.8).

¿Cómo puedo ejecutar una versión estable de QGis 1.8 de manera que no interfiera con mi otra compilación de QGis? La solución ideal será ejecutar todo desde una carpeta. Esto es posible para Windows (QGis en un Stick), pero no he encontrado Cualquier forma de hacer esto en sistemas Linux. No quiero usar distribuciones en vivo ni sistemas operativos completos.

Intenté compilar QGis estable como se muestra aquí , pero si intento ejecutarlo se bloquea diciendo:

Warning: !!! prefix path was requested, but it is not valid - we do not run from installed path !!!
Segmentation Fault

Lo más probable es que intente leer los archivos de configuración de mi carpeta de configuración .qgis en el directorio de inicio y falle porque no puede funcionar con las configuraciones y prefijos de 1.9dev.

¿Cómo puedo solucionar esto?

    
pregunta Curlew 20.02.2013 - 11:55

1 respuesta

10

Instale su compilación QGIS 1.8 en un directorio en su directorio de inicio. Deberías poder ejecutarlo desde allí. Si obtiene un error de ruta de prefijo, intente configurar lo siguiente (se supone que mi instalación está en qgis_1.8 en mi directorio de inicio):

export LD_LIBRARY_PATH=/home/gsherman/qgis_1.8/lib
export QGIS_PREFIX_PATH=/home/gsherman/qgis_1.8

Puede verificar a qué bibliotecas está haciendo referencia la versión 1.8 mediante:

ldd /home/gsherman/qgis_1.8/bin/qgis
    
respondido por el gsherman 02.03.2013 - 00:58

Lea otras preguntas en las etiquetas