Folleto que procesa mosaicos TileMill en el orden incorrecto

14

Estoy perplejo, y muchas búsquedas no han resultado útiles.

Estoy en el primer paso de lo que finalmente será un mapa con tres capas ráster y tres capas de marcadores (con controles para alternar entre los rásteres y sus datos asociados, con ventanas emergentes / información sobre herramientas para los datos), pero no se puede hacer que los mosaicos de Tilemill se procesen correctamente. (Creé los rásteres en QGIS, los pasé por GDAL para colorearlos y volverlos a proyectar, y luego los puse en TileMill).

A ingenio: EsoesenChrome.EstoesSafari:

Y aquí está el código, que me parece bastante inocuo (he comentado todo excepto los mosaicos en este punto, así que eso es todo lo que he incluido):

<html>
<head>
 <title> - Leaflet demo</title>
 <script type='text/javascript' src="http://cdn.leafletjs.com/leaflet-0.7.3/leaflet.js"></script><styletype='text/css'>html,body{width:100%;height:100%,margin:0;padding:0;}#map{width:700px;height:600px}img{margin:0px;padding:0px};</style><scripttype='text/javascript'>//<![CDATA[window.onload=function(){//onebaselayeronmapvarmap=newL.Map("map" ).setView([38.173,-94.384],5);
L.tileLayer('http://a.tiles.mapbox.com/v3/mtgmediagroup.beef2013/{z}/{x}/{y}.png', {
 attribution: 'Dani Friedland/MTG Media Group',
 maxZoom: 9
}).addTo(map);
</script>
</head>
<body>
<b>Map</b>
<div id="map"></div>
</body>
</html>

¿Alguien ha encontrado este problema alguna vez? Si es así, ¿cómo lo superaste? Estoy ansioso por comenzar con el resto del proceso de creación de este mapa (lo que por supuesto me refiero a "descubrir el siguiente problema por resolver").

Editado para agregar: Intenté volver a exportar un nuevo archivo MBTiles, subirlo como datos nuevos y crear un nuevo proyecto de Mapbox a partir de esos datos. No dados. El siguiente paso para aislar el problema sería configurar el archivo MBTiles en un servidor, omitiendo Mapbox, pero parece más probable que genere problemas que para solucionarlos.

    
pregunta Dani 04.06.2014 - 18:29

1 respuesta

20

Se te olvidó agregar el folleto CSS:

<link rel="stylesheet" href="http://cdn.leafletjs.com/leaflet-0.7.3/leaflet.css" />

También hay numerosos errores tipográficos en su código: por ejemplo, en la línea de hoja de estilo html, body{} . Verifíquelos antes de implementar en producción.

    
respondido por el Ilja Zverev 06.06.2014 - 16:29

Lea otras preguntas en las etiquetas