¿Advertencia de seguridad de Windows (ActiveX) al hacer clic en los campos en la herramienta ArcToolbox?

33

He estado ejecutando ArcGIS 10.5 en mi PC (Windows 10 Home) desde diciembre sin problemas. La semana pasada comencé a recibir advertencias de seguridad de ActiveX cuando hago clic en un campo de parámetro en cualquier herramienta de ArcToolbox.

  

AdvertenciadeseguridaddeWindows

    

UncontrolActiveXenestapáginapuedenoserseguroparainteractuarconotraspartesdelapágina.¿Quierespermitirestainteracción?

NopareceimportarsihagoclicenoNo,todavíapuedomodificarelcampoylaherramientaaúnfuncionabien.

Respondiendoa:

Respondiendo a No :

Estoy trabajando en las respuestas a ¿Por qué las herramientas de ArcToolbox dan ActiveX? ¿error? , aunque no parece haber una respuesta real en esa pregunta & A. Además, está de vuelta en Windows XP / 7 días con IE 7/8, y estoy ejecutando Win 10 con IE 11 (aunque nunca se usa). Si importa, los navegadores que utilizamos son Firefox 53.0 (64 bits) y Chrome 58.0.3029.81 (64 bits).

El problema que tengo es diferente, ya que está ocurriendo solo cuando hago clic en el campo de parámetro, no cuando abro la herramienta o, como leí en otros lugares, ArcMap. Los mensajes de advertencia en ese Q & A también tienen un texto diferente, por lo que puede ser un problema completamente diferente.

Abrí Internet Explorer (¡por primera vez desde que obtuve esta PC!) y observé la configuración de la Zona Local y todo para ActiveX está marcado como Habilitado , incluido uno sobre ejecución sin aviso:

Tambiéndeshabilitéotro"Solicitud automática de controles ActiveX", pero eso no detuvo la aparición del mensaje.

Pasé por las configuraciones sugeridas de ActiveX de Problema: Problemas con los controles ActiveX al iniciar ArcMap , actualizado todo configuración para coincidir (la única que tuve que cambiar fue la "Solicitud automática de controles ActiveX" que cambié en mis pruebas anteriores).

No se ha instalado ningún software nuevo en mi PC en la última semana.

¿Qué pudo haber causado que esto empiece a aparecer y cómo puedo solucionarlo?

    
pregunta Midavalo 24.04.2017 - 19:13

4 respuestas

12

Solución rápida y corta:

Publicación original

Encontré una solución para esto en el sitio web de ESRI: advertencia de error axtiveX . Un miembro del personal entró en el hilo y confirmó que se trata de un error en las versiones actuales de ArcGIS (en el momento de escribir este artículo, 10.5.1 era el más reciente).

Hasta ahora solo hemos visto que afecta a nuestros 1703 usuarios. No he probado en 1709, pero voy a imaginar que también les afecta a ellos. En mi organización no se nos permite cambiar la zona de seguridad como los estados de la otra respuesta (la política para esta configuración se controla mucho más arriba en la cadena), pero el enlace anterior tiene una solución alternativa (¿o una solución real?). He oído que se supone que tienen esto en 10.6.

  

Algunos de nuestros usuarios informaron este problema a Esri Support hace unas semanas.   Hemos reportado este problema como un defecto a nuestros equipos de desarrollo. Ellos   son muy conscientes y están investigando este problema al final.

     

"BUG-000105427: Las advertencias de control ActiveX aparecen al interactuar con   Herramientas de geoprocesamiento después de actualizar a Windows 10 versión 1703   (Actualización de los creadores) ".

Se vinculan a su artículo de la base de conocimientos sobre cómo solucionarlo: Error: se generan errores de script de Internet Explorer al ejecutarse cualquier herramienta de geoprocesamiento de ArcToolbox en algunos sistemas que implementan la redirección de carpetas

Esencialmente necesita copiar sus archivos .xsl en su carpeta arctoolbox, que para 10.5 (por defecto) se encuentra en C:\Program Files (x86)\ArcGIS\Desktop10.5\ArcToolbox\Stylesheets . Si bien el enlace a esta página muestra un error que se ve muy diferente al que usted describe, parece ser el mismo problema, solo una versión antigua de Internet Explorer. Confirmé que estaba funcionando para algunos de nuestros usuarios.

    
respondido por el Mgamerz 19.12.2017 - 16:44
12

Encontré una solución que funcionó para mí.

Cambio de configuración en el registro. Busque 1201 y el valor 0 (DWORD) en: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones%code%

Problema al ejecutar cualquier herramienta (en los foros de Geonet de Esri)

    
respondido por el Johan Hallgren 26.04.2017 - 08:55
12

La única diferencia importante que omite la mayoría de las sugerencias, y muy posiblemente esto es todo lo que se necesita para solucionar esto, es que en la Zona 0 se DEBE crear un nuevo DWORD 1201 si aún no existe . En otras palabras, cambiar todos los demás valores DWORD a "0" no funcionará a menos que también se agregue 1201.

La solución se puede encontrar aquí: enlace

Agregue una entrada "DWORD" llamada "1201" a la carpeta "HKEY_CURRENT_USER \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Internet Settings \ Zones \ 0" y establezca el valor en 0. Reinicie ArcGIS para que tenga efecto.

Veo que algunas publicaciones fueron eliminadas desde aquí; uno que identifica correctamente el problema como una actualización reciente de Windows que era, el otro que indica que agregar el DWORD resuelve el problema. Quizás, dejar la corrección de estas publicaciones para que suene más como una respuesta y no eliminarlas hubiera sido un mejor enfoque, ya que la respuesta actual aceptada aquí es incompleta.

    
respondido por el Jakub Sisak GeoGraphics 08.09.2017 - 17:09
1

Después de trabajar con este error más molesto en 10.5.1.7333, finalmente instalé 10.6 esta mañana. Estoy encantado de decir que este error ha desaparecido en 10.6.0.8321 !!

FWIW: el consejo de reemplazo de archivos .xsl no me funcionó en absoluto.

¡La actualización a 10.6 funcionó para mí!

    
respondido por el JamiRae 03.03.2018 - 16:56

Lea otras preguntas en las etiquetas