¿Instalar GDAL en el servidor Ubuntu de Linux?

28

apt-get install python-gdal instala la versión 1.6.0 y esto ya está instalado. Me gustaría instalar la versión 1.9.0.

¿Tengo que desinstalar 1.6.0 primero y luego compilar manualmente o hay un paquete apt-get que he perdido?

    
pregunta Robert Buckley 14.03.2012 - 18:28

4 respuestas

9

Puede obtener 1.9 de Ubuntugis (consulte enlace ).

Consulte enlace para obtener otras fuentes de binarios.

Si falla todo lo demás, puede compilar 1.9 desde las fuentes (http://trac.osgeo.org/gdal/wiki/BuildHints)

    
respondido por el Ian Turton 14.03.2012 - 19:47
53

Nota: esta es una respuesta para una versión anterior de GDAL, y hay versiones más nuevas disponibles (incluido current ) que puede compilarse de manera similar a esta respuesta. Simplemente reemplace los números de versión en los comandos a continuación.

Construir desde la fuente, con enlaces de Python:

sudo apt-get install build-essential python-all-dev
wget http://download.osgeo.org/gdal/gdal-1.9.0.tar.gz
tar xvfz gdal-1.9.0.tar.gz
cd gdal-1.9.0
./configure --with-python
make
sudo make install

Además, algunas distribuciones de Linux requieren que la memoria caché de la biblioteca compartida se actualice después de la instalación:

sudo ldconfig
    
respondido por el Mike T 14.03.2012 - 20:37
6

En caso de que la pregunta formulada aún fuera relevante, logré instalar Python-Gdal en Ubuntu 14.04 (Trusty) simplemente usando:

apt-get install python-gdal

    
respondido por el Hakim 20.08.2015 - 16:22
4

Puedes obtener 1.9 de Ubuntugis (consulta enlace ) mientras ejecutas Ubuntu 10.04 Lucid. 1.9 fue construido para Lucid para el OSGEO Live DVD y pronto estará disponible para otras versiones de Ubuntu (ish). Fuente: tráfico de correo electrónico en la lista de correo de UbuntuGIS.

    
respondido por el Luke 15.03.2012 - 02:51

Lea otras preguntas en las etiquetas