Instale QGIS 2.14 Essen en Ubuntu 16.04 Xenial

26

Tengo problemas para instalar QGIS en Xenial.

versión 'debian'

Cuando trato de usar la versión debian (es decir, sin las dependencias ubuntugis ) obtengo los siguientes errores (tenga en cuenta que no hay una versión xenial , así que he usado wily al configurar sources.list ):

~$ sudo apt install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+23wily) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
 qgis : Depends: libgdal.so.1-1.11.2 but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: qgis-providers (= 1:2.14.1+23wily) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+23wily) but it is not going to be installed
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass7-2.14.1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

versión 'ubuntugis'

Después de fallar con la versión debian , probé la versión ubuntugis agregando ubuntugis-unstable PPA (otra vez usé la versión wily de ubuntugis para mantener la coherencia con la versión QGIS):

:~$ sudo apt update 
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [92.2 kB]
Hit:2 http://gb.archive.ubuntu.com/ubuntu xenial InRelease                                                                                                
Get:3 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily InRelease [15.5 kB]                                                                     
Get:4 http://gb.archive.ubuntu.com/ubuntu xenial-updates InRelease [93.3 kB]                                                                                    
Hit:5 http://ppa.launchpad.net/git-core/ppa/ubuntu xenial InRelease                                                                                             
Hit:6 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease                                                                                   
Hit:7 http://gb.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                        
Get:8 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily/main amd64 Packages [4,297 B]                       
Get:9 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily/main i386 Packages [4,307 B]                  
Get:10 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu wily/main Translation-en [2,463 B]     
Ign:11 http://linux.dropbox.com/ubuntu wily InRelease                                                  
Hit:12 http://linux.dropbox.com/ubuntu wily Release                      
Ign:14 https://cloud.r-project.org/bin/linux/ubuntu xenial/ InRelease
Hit:15 https://cloud.r-project.org/bin/linux/ubuntu xenial/ Release
Ign:17 http://qgis.org/ubuntugis wily InRelease    
Err:18 http://qgis.org/ubuntugis wily Release
  404  Not Found [IP: 104.27.138.220 80]
Reading package lists... Done
W: https://cloud.r-project.org/bin/linux/ubuntu/xenial/Release.gpg: Signature by key E298A3A825C0D65DFD57CBB651716619E084DAB9 uses weak digest algorithm (SHA1)
E: The repository 'http://qgis.org/ubuntugis wily Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

La línea E: The repository 'http://qgis.org/ubuntugis wily Release' does not have a Release file. parecía bastante fatal, así que probé trusty (la versión compatible más reciente). Esta actualizado, pero al intentar instalar:

:~$ sudo apt install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
 qgis : Depends: libgdal.so.1-1.11.2
        Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
        Depends: libgeos-c1 (>= 3.4.2) but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: qgis-providers (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
                     Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass7-2.14.1 but it is not going to be installed
                     Depends: grass-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Finalmente, en aras de la integridad, con la versión xenial de ubuntugis :

$ sudo apt install qgis python-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
 qgis : Depends: libgdal.so.1-1.11.2 but it is not installable
        Depends: libgdal1h (>= 1.8.0) but it is not installable
        Depends: libgeos-c1 (>= 3.4.2) but it is not installable
        Depends: libgsl0ldbl (>= 1.9) but it is not installable
        Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: qgis-providers (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
        Recommends: qgis-provider-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+20trusty-ubuntugis) but it is not going to be installed
                     Depends: libgdal1h (>= 1.8.0) but it is not installable
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass7-2.14.1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Esperemos que pronto esté disponible una versión de QGIS para Xenial, pero ¿alguien ha logrado instalar QGIS 2.14 en Xenial?

    
pregunta Phil 29.04.2016 - 11:43

6 respuestas

35

Parece que en realidad hay soporte Xenial en el repositorio de Debian y aunque no he probado la siguiente solución, creo que vale la pena intentarlo.

Antes de intentar lo siguiente, desinstalaría todos los paquetes qgis anteriores usando sudo apt-get remove qgis python-qgis qgis-plugin-grass y eliminaría deb http://qgis.org/debian wily main y deb-src http://qgis.org/debian wily main de /etc/apt/sources.list .

EDIT Para eliminar los paquetes que se instalan como dependencias automáticas al instalar qgis, ejecute el comando sudo apt-get autoremove después de ejecutar los comandos anteriores para eliminarlos. EDITAR FINAL

Lo siguiente está adaptado de qgis.org para incluir la palabra clave xenial .

Agregue lo siguiente a su /etc/apt/sources.list :

deb http://qgis.org/debian xenial main

deb-src http://qgis.org/debian xenial main

luego ejecuta:

sudo apt-get update

sudo apt-get install qgis python-qgis qgis-plugin-grass

Estoy muy interesado en saber si lo haces funcionar.

    
respondido por el JonasPedersen 30.04.2016 - 10:37
4

Si no está seguro de qué distribuciones son compatibles, ingrese la url después de deb en su navegador y navegue a la carpeta dists .

Luego ves que http://qgis.org/debian/dists/ es hasta xenial, mientras que http://qgis.org/ubuntugis/dists/ solo es compatible y confiable.

Otras fuentes son ubuntugis stable ppa , que actualmente solo tiene QGIS 2.8.3 para trusty, mientras ubuntugis unstable sigue en QGIS 2.8.1. Últimamente ha habido alguna actividad en esos ppa, así que mantén un ojo en ellos.

Y QGIS 2.14.1 también está disponible para Debian sid de los paquetes principales de Debian, mientras que los puertos de soporte jessie ofrecen 2.8.6 (igual que para Ubuntu).

ACTUALIZAR

El PPA de ubuntugis-unstable también es compatible con QGIS 2.14.1 para Xenial también.

    
respondido por el AndreJ 29.04.2016 - 16:10
3

Como usuario de Linux Mint 'Cinnamon 17.3 también tuve problemas con estas "dependencias no satisfechas (libgdal.so.1-1.11.2 etc.)" y tuve que actualizar el ppa. Hice esto al incluir los siguientes enlaces en el /etc/apt/sources.list :

deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
deb-src http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty main
    
respondido por el andrasz 04.05.2016 - 15:13
0

Para instalarlo en xenial, solo necesitas:

sudo apt-get update
sudo apt-get install qgis
    
respondido por el leCrazyEngineer 21.09.2016 - 02:30
0

A pesar de implementar muchos consejos encontrados en Internet, no pude hacer que QGIS se instalara en Ubuntu 16.04 hasta que encontré este breve y útil video: enlace

Hasta entonces, también tenía problemas con los mensajes sobre varias "dependencias no cumplidas" y "paquetes faltantes / rotos" (sugerencia para el creador del video: entusiasta de Linux)

Estos son los pasos que debe seguir en el terminal:

Paso 1. Escriba:

sudo nano /etc/apt/sources.list [presione enter]

Paso 2. Escriba:

deb https://qgis.org/ubuntugis-ltr xenial main

deb-src https://qgis.org/ubuntugis-ltr xenial main    

deb http:/ppa.launchpad.net/ubuntugis-unstable/ubuntu/ubuntu xenial main

[Presione Intro, y cuando se le solicite "Guardar buffers modificados" , presione la tecla y]

Paso 3. Escriba:

wget -O - https://qgis.org/downloads/qgis-2017.gpg.key | gpg --import [presione enter]

Escribe:

gpg --fingerprint CAEB3DC3BDF7FB45 [presione enter]

Paso 4. Escriba:

sudo apt-get update [presione enter]

Paso 5. Escriba:

sudo apt-get install qgis-server python-qgis [presione enter]

¿Desea continuar? - [presione la tecla y]

¿Instalar estos paquetes sin verificación? [presione la tecla y]

QGIS se instalará y, posteriormente, lo encontrará entre su lista de programas. Buena suerte, espero que esto haya ayudado. **

    
respondido por el Whisker 01.05.2018 - 13:39
-2

Debian Xenial trabaja para mí. Primero instalo bleachbit a un autoremove, limpiar.

Lo anterior fue traducido de Google desde:

  

Debian Xenial fonctionne pour moi. J'ai d'abord installé bleachbit   pour faire un autoremove, clean.

    
respondido por el jojobound 07.10.2016 - 23:47

Lea otras preguntas en las etiquetas