¿Soluciones para el complemento de mapa de calor en QGIS?

1

En QGIS 2.8, el complemento de mapa de calor se rompió CRS. Actualicé a 2.10, ahora en el complemento el diálogo está roto: no te permite elegir el formato.

Represento capas para atlas con estilo de mapa de calor. Pero necesito exportarlo a GeoTIFF, y no veo una manera de hacer esto.

La actualización de QGIS no es fácil en Ubuntu, ya que funciona normalmente cuando se instala desde un PPA, pero la instalación desde fuentes o la descarga de debs es muy dolorosa.

¿Hay alguna solución?

Un ejemplo de línea de comando también servirá.

editar aquí hay una captura de pantalla. La lista de formatos está vacía, y si escribo la extensión de archivo manualmente como lo hice aquí, todavía no lo permite, mostrando un mensaje que indica que no se ha elegido el formato.

Mientrastanto,enotrocuadrodediálogo,laopcióndeformatofuncionacorrectamente:

Versiones:

    
pregunta culebrón 21.10.2015 - 14:50

1 respuesta

2

Estoy ejecutando QGIS 2.10 en Linux Mint 17.2 (basado en trusty), y en el complemento Heatmap el menú desplegable de formatos disponibles no está vacío, por lo que su problema no es un problema general con QGIS ejecutándose en LM / Ubuntu. No estoy seguro de cómo reproducir este problema.

Sin embargo, sugieres que el problema surgió después de una actualización a 2.10. Se me ocurre que una cantidad significativa de funcionalidad de QGIS (especialmente para los complementos) depende de python-qgis . Este podría explicar la diferencia entre Heatmap (plugin) y Raster Calculator (que creo que es el núcleo), por lo que verificaría que tienes python-qgis que instalado con

apt-cache policy python-qgis

e instálalo si falta.

Otra preocupación es que dices que has actualizado a 2.10 desde ubuntugis-unstable PPA . Sin embargo, por lo que puedo decir, ubuntugis-unstable solo sube a la versión 2.8. No estoy seguro de por qué esto llevaría a una funcionalidad incompleta. ¿Quizás tienes QGIS 2.10 pero python-qgis 2.8? La discrepancia implica que es posible que no haya instalado desde el repositorio que deseaba.

Si está ejecutando Ubuntu Trusty, recomendaría instalar 2.10 desde el repositorio de QGIS, pero comience por purgar su instalación actual:

sudo apt-get purge qgis python-qgis

Luego agrega las siguientes líneas a /etc/apt/sources.list :

deb http://qgis.org/ubuntugis trusty main
deb-src http://qgis.org/ubuntugis trusty main

Nota: aunque puede editar /etc/apt/sources.list directamente, en la práctica prefiero usar la herramienta Fuentes de software (disponible de forma independiente o desde el menú Synaptic) para agregar nuevas líneas de origen de repositorio.

Después de hacer eso, actualice y reinstale los paquetes qgis y python-qgis a través de Synaptic o:

sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass

Estas instrucciones se tomaron de enlace . También puedo confirmar que funcionan, ya que así es como tengo QGIS 2.10 instalado en LM 17.2. Estas son también las instrucciones para la versión diseñada para trabajar con las dependencias de ubuntugis, y requiere el uso del PPA inestable de ubuntugis, que ya está utilizando. Pero si está utilizando una versión más reciente de Ubuntu que Trusty, debe elegir la versión adecuada y no usar las dependencias de ubuntugis. Consulte el enlace para obtener más instrucciones.

    
respondido por el Lee Hachadoorian 21.10.2015 - 21:12

Lea otras preguntas en las etiquetas