¿Se actualizará el complemento OpenLayers para QGIS3?

46

Al buscar el complemento OpenLayers, muestra que este complemento es incompatible con la versión QGIS 3.0. ¿Esto será actualizado? ¿Hay otra forma de agregar imágenes de Google o cualquier otra imagen aérea que no sea a través de este complemento?

Noté que la capa de OpenStreetMap que había estado usando con QGIS 2 sigue funcionando ahora que estoy usando QGIS 3, pero la capa de Google Satellite ya no aparece.

    
pregunta TMAC_0819 26.02.2018 - 19:18

6 respuestas

60

En QGIS 3 use los mosaicos XYZ en el navegador de datos

utilizar

  

http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z}&s=Ga

Actualizacióndel12demarzode2018

HayunscriptdePythonquesecargaráenmúltiplesmosaicosxyzdisponiblesaquí enlace (el crédito completo es para Klas Karlsson enlace )

    
respondido por el Mapperz 26.02.2018 - 23:17
25

Qgis 3 tiene una nueva arquitectura de complementos, por lo que los complementos no son inmediatamente compatibles con esta nueva versión. Desde el repositorio de origen parece que esperan el lanzamiento oficial de QGIS 3 para producir una nueva versión del complemento.

Además de esto, ahora tiene la opción de usar la fuente XYZ Tile para declarar algunos mapas resbaladizos. por ejemplo, puede usar enlace para openstreetmap.

Encontrará un montón de recursos en enlace (busque TMS)

    
respondido por el Billy34 26.02.2018 - 22:19
4

El QuickMapServices (o QMS) hace que sea muy fácil agregar mapas base de muchas fuentes diferentes a su QGIS 3 proyecto.

De forma predeterminada, obtienes bastantes mapas base, pero puedes agregar cientos de mapas base adicionales contribuidos por el usuario yendo a QuickMapServices - > Configuración - > Más servicios - > Obtener el paquete contribuido

Use la herramienta Buscar QMS para ubicar rápidamente los mapas base.

    
respondido por el Rayner 18.10.2018 - 09:58
3

Hice un secuencia de comandos genérica para cargar desde CSV cualquier tesela XYZ

Es más genérico que el de Klas Karlsson (no es un contenido codificado) pero tendrá que establecer capas adicionales por su cuenta, ya que el CSV predeterminado que se proporciona no contiene muchos mapas base predeterminados.

QuickMapServices, un complemento alternativo al complemento QGIS OpenLayers, ahora es compatible con QGIS 2.x & 3.0 como se indica en este anuncio de la publicación del blog

    
respondido por el ThomasG77 22.03.2018 - 23:34
1

Para descargar datos vectoriales de OpenStreetMap puede usar OSMDownloader. Descarga archivos .osm y los carga automáticamente en QGIS3. Acabo de terminar la adaptación. Consulte aquí cómo usarlo: enlace

    
respondido por el lcoandrade 06.04.2018 - 18:20
1

Ahora hay una versión experimental del complemento OpenLayers disponible en el QGIS Python Plugins Repository , que es compatible con QGIS desde la versión 3.0.1 en adelante.

    
respondido por el fdetsch 24.07.2018 - 13:00

Lea otras preguntas en las etiquetas