Error de complemento de OpenLayers: la latitud o la longitud excedieron los límites

18

Soy consciente de que el error 'traceback' del complemento OpenLayers se ha solucionado antes, así que disculpas por plantear el problema una vez más. Desafortunadamente para mí, las soluciones publicadas estaban muy por encima de mi cabeza, por ejemplo. utilizando soluciones y códigos publicados en github, etc. Lo encuentro alucinante.

Si alguien pudiera publicar una respuesta paso a paso para un principiante absoluto como yo, ¡se lo agradecería eternamente! Gracias. Espero que algún día pueda aportar algo.

Se lee el mensaje de error:

An error has occured while executing Python code:

Traceback (most recent call last):
  File "C:/Users/MCMA1580/.qgis//python/plugins\openlayers_plugin\openlayers_plugin.py", line 48, in addLayer
    self.__plugin.addLayer(self)
  File "C:/Users/MCMA1580/.qgis//python/plugins\openlayers_plugin\openlayers_plugin.py", line 190, in addLayer
    self.__setMapSrsGoogle()
  File "C:/Users/MCMA1580/.qgis//python/plugins\openlayers_plugin\openlayers_plugin.py", line 249, in __setMapSrsGoogle
    extMap = coodTrans.transform(extMap, QgsCoordinateTransform.ForwardTransform)
QgsCsException: forward transform of
(0.884883, 2.549197)
PROJ.4: +proj=longlat +datum=WGS84 +no_defs +to +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 +y_0=0 +k=1.0 +units=m [email protected] +wktext  +no_defs
Error: latitude or longitude exceeded limits
    
pregunta Almac 09.04.2013 - 16:59

1 respuesta

28

La forma más segura de iniciar el complemento de openlayers es

  • configura el proyecto CRS en EPSG: 3857
  • asegúrese de que on-the-fly-projection esté habilitado
  • agregue la capa de fondo de capas abiertas que desee
  • carga otras cosas que puedan tener otra capa CRS, como WGS84 en lat / lon grados
  • guardar el proyecto
respondido por el AndreJ 09.04.2013 - 17:16

Lea otras preguntas en las etiquetas